Связаться со мной:

Мультиверсионность php c VestaCP на выделенных серверах и VDS

На наших выделенных серверах и VDS теперь доступен шаблон с VestaCP и версиями php от 5.3 до 7.3. Установка через техподдержку.
Проходите по ссылке или кликайте на баннер вверху страницы, в комментариях к заказу напишите что вам нужен шаблон с vestacp-multiphp.

Поделиться
Отправить
22 октября   php   php7   phpmgr   vesta control panel   vestacp
1 комментарий
skurudo

Спасибо за подсказку :)

Пока можно выкрутиться вот так — просто используя билды:

wget —no-check-certificate https://www.php.net/distributions/php-7.1.32.tar.bz2 &&
wget —no-check-certificate https://www.php.net/distributions/php-7.2.23.tar.bz2 &&
wget —no-check-certificate https://museum.php.net/php5/php-5.6.9.tar.bz2 &&
wget —no-check-certificate https://museum.php.net/php5/php-5.5.6.tar.bz2 &&
wget —no-check-certificate https://museum.php.net/php5/php-5.4.9.tar.bz2

mkdir -p /opt/php/src/bzips/
mv php-* /opt/php/src/bzips/

git clone https://github.com/petranikin/mgrvphp.git
cd mgrvphp
bash mgrvphp

7.1.32 7.2.23 5.5.6 5.4.9 5.6.9

Петр Аникин

Да не за что)
Стоит уточнить для тех кто не в курсе. Что если скрипт находит архив с исходниками php нужной версии в /opt/php/src/bzips/, то он не пытается скачать сорцы с php.net, а сразу начинает сборку из имеющегося архива. Поэтому такой лайфхак работает.

Популярное